Support Center

ActiLife 6.x System Requirements

Last Updated: Jul 26, 2016 06:03PM CDT

Below are the minimum and recommended Hardware and Software requirements for ActiLife 6.x

(Note: ActiLife 5.x and earlier is no longer supported and will only run on a dedicated Windows PC).

Hardware Requirements:

PC:

    • 2 GHZ Single Core 32-bit (x86) or 64-bit (x64) processor (Intel or AMD); 2 GHZ x64 Dual Core or higher recommended
    • 2 GB of system memory; 4 GB or higher recommended (64-bit processor required for more than 4 GB memory)
    • 1 GB of available hard drive space
    • Video Card capable of at least 1280x1024 resolution at 32-bit color depth
    • USB 2.0 Compliant Port
    • Internet Access recommended (for Activation, Auto-Update, and Data Vault features)

MAC:

    • Intel Core 2 Duo, Core i3, Core i5, Core i7, or Xeon processor (Core Solo and Core Duo processors are no longer supported)
    • 2 GB of system memory; 4 GB is recommended to run Windows 7/8 in a virtual machine or if your host OS is Lion
    • 1 GB of free disk space on the boot volume (Macintosh HD) for Parallels Desktop (v7.0+) or VMWare Fusion (v5.0.0+) installation
    • Approximately 15 GB of disk space for each virtual machine
    • Video Card capable of at least 1280x1024 resolution at 32-bit color depth
    • USB 2.0 Compliant Port
    • Internet Access recommended (for Activation, Auto-Update, and Data Vault features)

 

Software Requirements:

PC: ** Effective April 8th, 2014, Windows XP will no longer be supported. Please see Microsoft's official announcement here **

    • Windows XP, SP3 (32-bit only), Vista/7/8/10 (32 or 64-bit); Windows 7, 8 or 10, 64-bit recommended
      • Dot NET Framework 4.0. More information here
    • Linux Distribution based on Kernel Version 2.6 or higher (kernel v3.0+ strongly recommended), 32 or 64-bit; 64-bit recommended
      • Tested on Linux Mint, Fedora, Ubuntu, Debian, Slackware, CentOS, and openSuSE
      • X.org or XFree86.org X Server
      • Gnome 2/3+ or KDE 4+ Desktop Environment
      • VMWare WorkStation (v9.0.0 or greater)

Mac:

Software capable of opening PDF files (to view PDF Exports) - Adobe Reader/Acrobat, CutePDF, others here.
Software capable of opening CSV/XLSX files (to view CSV/XLSX exports) - MS Office 2007 or greater, LibreOffice, OpenOffice.

 

ActiLife must be installed on your local computer and not to a network location. It must installed with Local Administrative permissions. It is also strongly recommended to run ActiLife with Local Administrative privileges to avoid permissions issues when accessing devices. It will not function in a Terminal Services environment and does not work properly in environments that utilize Roaming Profiles or Profile Folder redirection.

 

** Linux and MacOS requires a Class 2 Hypervisor like VMWare Workstation (Linux), VMWare Fusion (MacOS), or Parallels (MacOS); ActiLife will not run natively on Linux/MacOS. Oracle's VirtualBox Hypervisor is NOT supported and neither ActiLife nor our devices will not function properly in that environment. You can also setup a dual-boot environment like BootCamp on the Mac. All devices must have the latest firmware release installed to function properly in these environments. Current firmware versions can be found here.

While our software and devices should function in these alternative environments, we can only provide Basic Technical support for these configurations. Our products are ONLY fully supported when running in a native Windows environment.

Contact Us

84597daf644fbf443ca13c8a01998d15@actigraph.desk-mail.com
https://cdn.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete