Support Center

My USB Hub Isn't Working. Is It Defective?

Last Updated: Nov 28, 2016 02:01PM CST

Users regularly purchase the 7 port powered USB hubs from our store for the purposes of connecting multiple devices at once and in some cases, only a few devices are visible in the devices grid. Because these Hubs are Active (that is, they require an external power source to function properly), users are unaware that they must connect both the USB connection and the AC Adapter. Failure to do so means that the Hub is unable to provide enough electrical current for more than just a few devices. Each device requires approximately 250 milliamps (mA) to be available via the USB connection.

If you have connected several devices but find that only 2 or 3 are visible, make sure that you have connected the Hub to a working electrical outlet and that the power connector is also properly connected to the Hub itself. In almost all cases, this will resolve the issue you are having.

Hub_Connections.jpg

 

If you need any further assistance, please go to our support portal at https://help.theactigraph.com/home. From here, you can view many helpful FAQ's and Troubleshooting Articles; log in to check any existing Support Requests; or create a new Support Ticket if you are unable to find a solution. You can also email us at support@theactigraph.com or give us a call at (877) 497-6996, Monday through Friday, 8 am to 5 pm CST.

Contact Us

84597daf644fbf443ca13c8a01998d15@actigraph.desk-mail.com
https://cdn.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete